Subscribe to updates
Applepay errors
Resolved
·
Partial outage
Thu, Nov 13, 2025, 10:18 AM
(
3
weeks ago)
·
View all updates
Affected components
Nov 13, 2025, 10:16 AM
10:18 AM
Payment Provider
1 affected component
Updates
Resolved
Issue has been resolved.
Thu, Nov 13, 2025, 10:18 AM
Investigating
Applepay
is experiencing issues. Investigating.
Thu, Nov 13, 2025, 10:16 AM
Powered by
Privacy policy
·
Terms of service